Trying to compile for Windows Phone 7

Monkey Targets Forums/XNA/Trying to compile for Windows Phone 7

Tri|Ga|De(Posted 2012) [#1]
I compile my project for XNA and opens the project in Visual Studio 2010 express.
But I get an error:

One or more projects in the solution were not loaded correctly. Please see the Output Window for details.

In solution explorer it says:
MonkeyGame (unavailable)
Windows Phone Copy of MonkeyGame (unavailable)
Xbox 360 Copy og MonkeyGame (unavailable)

If I right click on the any of the item in the solution explorer I do not get a option to copy to Window Phone.

If I right-click on Windows Phone Copy of MonkeyGame and select "Reload Project" I get an "Object reference not set to an instance of an object" error.

I tried Marks FirePainter example but get the same error.

What can I do to compile my game to the Windows Phone simulator?

Xaron(Posted 2012) [#2]
Have you installed that Windows Phone stuff correctly?

Tri|Ga|De(Posted 2012) [#3]
What Windows phone stuff.

I installed Viual Developer for phone express, is it that you mean?

skid(Posted 2012) [#4]
Are you letting monkey fully build the projects first, are you sure it does not list any errors?

If you are saving your projects or Monkey in Program Files or some other UAC controlled directory then don't.

Also there are two versions of Visual Studio Express, you need the following:

'Visual C# 2010 Express and XNA 4.0 are requred for XNA target support and are currently available here:

Tri|Ga|De(Posted 2012) [#5]
When I compile in TED I get 9 warnings and 0 errors.

When I load the project into Visual STudio I get this:
C:\Users\JensThomsen\Desktop\MonkeyPro\Trisect Development\Planet Defender\\xna\MonkeyGame\MonkeyGame\MonkeyGame.csproj : error  : Object reference not set to an instance of an object.

C:\Users\JensThomsen\Desktop\MonkeyPro\Trisect Development\Planet Defender\\xna\MonkeyGame\MonkeyGame\Xbox 360 Copy of MonkeyGame.csproj : error  : Object reference not set to an instance of an object.

C:\Users\JensThomsen\Desktop\MonkeyPro\Trisect Development\Planet Defender\\xna\MonkeyGame\MonkeyGame\Windows Phone Copy of MonkeyGame.csproj : error  : Object reference not set to an instance of an object.

MonkeyGame for Windows Phone is still unavailable.

I reinstalled Visual Studio and XNA.
I installed Service Pack for Visual Studio.

I saving my game under folder MonkeyPro on the desktop.

Xaron(Posted 2012) [#6]
Have you opened the sln file with VS or the project files?

If you like you can send me your XNA project (no need for the original Monkey source if you don't like that!)

Tri|Ga|De(Posted 2012) [#7]
I'm opening the SLN file.

I have put the file on my server.

Get the file.

Xaron(Posted 2012) [#8]
Got it. Works great for me.

Just a note: Set the windows phone copy as startup project! After that, do a right click on that project and choose "debug->start new instance" (or however this is called in the english version).

Tri|Ga|De(Posted 2012) [#9]
But my Windows Phone Copy of MonkeyGame is unavailable.

I can't do anything with it!

All three copy's of MonkeyGame is unavailable.

Xaron(Posted 2012) [#10]
Strange. I just use the VS Express version...

Tri|Ga|De(Posted 2012) [#11]
I'm using the VS 2010 Express version for Windows Phone.

Maybe I should uninstall VS and XNA and start all over.

Tri|Ga|De(Posted 2012) [#12]
Okay reinstalling got me a lot further.

But but but I'm not through yet!

If I try to run the project (F5) I get two errors.
1#, No devices are available to deploy project 'Xbox 360 copy of MonkeyGame"
2#, The current display adapter does not meet the emulator requirements to run XNA framework applications.

I did set the Windows Phone Copy of MonkeyGame as Startup project

Xaron(Posted 2012) [#13]
1) means you should select the emulator as target and not a real device to deploy to.
2) well ok... *g* what kind of gfx card do you have?

Tri|Ga|De(Posted 2012) [#14]
1) I can select any thing just click the run(F5 debug) button with "Windows Phone Emulator" grayed out.
2) I have a Geforce Go 7300 in my Lenovo laptop.

I removed the Xbox 360 from my solution and got rit of the first error. (I think)

I'm just trying to install a new DirectX version to see if that helps

Tri|Ga|De(Posted 2012) [#15]
I think my laptop does not run WDDm1.1 and thats why it will not work.
I'll try on my other laptop(newer) tomorrow.

Thank for all your help so far. I may be back with more questions if the other laptop does not work.

Xaron(Posted 2012) [#16]
Good luck!

Tri|Ga|De(Posted 2012) [#17]
Finally I got it working.
Moved to another(newer) laptop, reinstalled all the software.

So now I can check my game on the WP7 emulator and its working just fine.

Xaron(Posted 2012) [#18]
Great! So it will work on a real device as well!

Tri|Ga|De(Posted 2012) [#19]
Yes I just signed up for a Microsoft Developer Licence(or whatever its called)
And I hope I'll have my game ready for download on WP7 soon.

benmc(Posted 2012) [#20]
@Tri|Ga|De I too cannot seem to get my apps to compile and run on the emulator. It's error after error, uhg.

Would you mind listing all the things you installed on your newer laptop? I would like to start over too, but am not sure what to do.

Tri|Ga|De(Posted 2012) [#21]
I installed
Visual Studio C# 2010 Express
Visual Studio for Phone Development
Service Pack 1 for Visual Studio 2010 Express

I thinkt this is the list.

benmc(Posted 2012) [#22]
Awesome, thank you, I'll give it a whirl.