A totally nOOb question about targets.

Monkey Archive Forums/Monkey Discussion/A totally nOOb question about targets.

Steve Ancell(Posted 2013) [#1]
I downloaded monkeypro70g from my account...

The IDE opens fine but there's no WinXP or Win7 targets, how do I get around this?. I know that monkey can target WinXP, I've played enough of Jayenkai's games to know this, but I feel a right banana for not knowing how to get it to work. :-/

BigAnd(Posted 2013) [#2]
Do you have "Glfw_Game" in the targets?

If so, thats what you use for Windows, assuming you are on a Windows PC.

rIKmAN(Posted 2013) [#3]
There is also the "Xna_Game" target - although I'm not sure if this works XP and you need to install VC2010.

MikeHart(Posted 2013) [#4]
In the monkey help, there is the target SDK section. Depending on the OS you use, you need to install certain SDK's/tools. Also you might need to change the config file in the bin folder of your Monkey installation.

Steve Ancell(Posted 2013) [#5]
Thanks for the advice guys, yes it has Glfw_Game in the dropdown target list.

Steve Ancell(Posted 2013) [#6]
Glfw_Game seems to be working fine now that I found out that I need VC++ 2010 installed, that'll teach me for not reading the instructions first.

MikeHart(Posted 2013) [#7]
LOL, glad you got it working. It helps to study the help files. With all the different targets and the flexibility of Monkey, you need to do some setup work at first. But once that is done, developing is smooth. At least that was my experience so far.
I develop mostly with the HTML5 target cause I see the results quicker on the screen.

Steve Ancell(Posted 2013) [#8]

I develop mostly with the HTML5 target cause I see the results quicker on the screen.

Thanx for the tip, that makes sense ;). I will keep that in mind. :)

rIKmAN(Posted 2013) [#9]
You don't *have* to use VC2010 for GLFW, you can use GCC as well.
Set the corresponding paths in config.<platform>.txt for your GCC install directory and then use the following compiler directive in your code:

Steve Ancell(Posted 2013) [#10]
Thanx rIKmAN. ;)

Sensei(Posted 2013) [#11]
rIKmAN, can you clarify what needs doing exactly to use GCC instead?
I'm having issues with GLFW not compiling on my Win7 PC due to some C1033 error I am unable to resolve.
Is the GCC path the MinGW path?

That is what I currently have on my config.

marksibly(Posted 2013) [#12]
Leave off the \MinGW32...ie:


rIKmAN(Posted 2013) [#13]
Yep pretty much what Mark says.

I installed GCC (tdm-gcc-4.7.1-2.exe) into "C\:MinGW" - (The MinGW folder contains "bin", "doc", "include", "lib" etc folders)

So the line in my config file is:
Hope that example helps.

Sensei(Posted 2013) [#14]
After still getting C1033 errors and the build still making vc2010 folders, I dug around the config files and discovered that the problem was:

I got it working by changing it the path as suggested above and this to

Might be a Windows setting to use MINGW instead of GCC?

Thanks guys!

DruggedBunny(Posted 2013) [#15]
#GLFW_USE_MINGW is correct -- for some reason it seems to have briefly been replaced/supplemented with #GLFW_USE_GCC, but now (as far as I can tell) only #GLFW_USE_MINGW is valid.