Commands in My Engine

Blitz3D Forums/Blitz3D Programming/Commands in My Engine

ala_samodi(Posted 2007) [#1]
in my Direct3D 9.0 Engine ,

Do you want commands system to be like :

DX9_LoadMesh mesh_number,filename,parent

or

mymesh = DX9_LoadMesh (filename,parent)

best regards


JA2(Posted 2007) [#2]
Personally, I would like to see blitz3d-like commands such as "mymesh = LoadMesh filename,parent"


t3K|Mac(Posted 2007) [#3]
yeah blitz style would be easier for all of us ;)


Paul "Taiphoz"(Posted 2007) [#4]
usein the exact same commands would be nice just add a suffix in front of them like DX9loadanimmesh() or DX9_loadanimmesh()

etc.. that way for at least most of the commands people who know B3D wont really need to learn them as they will already know the command and only have to add the suffix or prefix.


mongia2(Posted 2007) [#5]
mymesh = dx9_LoadMesh (filename,parent)


puki(Posted 2007) [#6]
Yeh, just use Blitz3D stuff and put the old 'dx9' in front of it.


JA2(Posted 2007) [#7]
Just curious, will your directx 9 engine be capable of something like this?

http://www.youtube.com/watch?v=f6-H3AkNd6o


Beaker(Posted 2007) [#8]
mymesh = DX9_LoadMesh (filename,parent)


ala_samodi(Posted 2007) [#9]
hi again;

thanx for your replies.

[JA2] :
what I have seen in that video is a Real rendering technique.

but My Engine have the following features[ I saw it in that video]

1- Bump Mapping.
2- Parallax mapping.
3- Light maps.[not finished yet].

soon I will add Realistic water surfaces.

another question I would to ask;

do you want cameras,lights,meshs,... to have their own commands for movement,rotation,... , Like:

DX9_PositionCamera mycamera,x,y,z
DX9_PositionLight mylight,x,y,z

or

a general system that manages movement,rotation,... ,Like:

DX9_PositionEntity my_entity,x,y,z
or
DX9_PositionObject my_object,x,y,z

such that my_entity : mycamera,mylight,...
or
my_object : mycamera,mylight,...


VIP3R(Posted 2007) [#10]
mymesh = DX9LoadMesh(filename,parent)

Please consider NOT using the underscores ( _ ), they're an abomination and nothing but a hindrance IMHO.

DX9PositionEntity / DX9PositionObject, although I wouldn't mind the dedicated commands either.

Good luck with the engine, looking forward to it :)


slenkar(Posted 2007) [#11]
DX9positionentity


t3K|Mac(Posted 2007) [#12]
keep it as close as possible to the b3d commands. people will thank you ;)


jfk EO-11110(Posted 2007) [#13]
I think the underscore gives better readabilty you'll See typos better in

DX9_PositionMesh

than in

dx9positoinmesh

I'd suggest to use an entity system like Blitz does. This way it will be easy to convert existing blitz3D code!


puki(Posted 2007) [#14]
Mmm, I'm wondering if people now want the DX9?

Sniff.


VIP3R(Posted 2007) [#15]
Interesting how you've used all lower case to prove your point jfk, since capitalised function names are just as readable without the underscore.

Blitz's native functions don't have underscores either, I don't see many folks complaining about their readability.

Btw, underscores won't help people who can't type readability correctly :P


puki(Posted 2007) [#16]
http://www.blitzbasic.com/Community/posts.php?topic=68866

Woof, Woof!


ala_samodi(Posted 2007) [#17]
thanx all

[puki] :

The Engine will be ready after 50-60 days from now.

so if you don't beleive me now, after two months you will see.

bye


cyberyoyo(Posted 2007) [#18]
we are waiting ala_samodi, you had better not disappoint us ;)


Naughty Alien(Posted 2007) [#19]
oh boy..now is new 2 months after previous 3 ?? You said 3 weeks far as i can remember, until first demo shows up..