Restarting without my permission

Archives Forums/Win32 Discussion/Restarting without my permission

Tricky(Posted 2016) [#1]
Well, I turn on my deffragler to defragment my portable harddrive.
I go to bed, as that is a long process anyway and while I sleep I don't have to waste time while defragging.

When I wake up in the morning my computer suddenly shows my Linux login screen and I am suddenly in Linux..... Right....

What happened?

Windows 10 found an updated installed it and restarted my computer, all without my permission. Not really a problem if I wan't defragging (and if GRUB wasn't set up to run Ubuntu as main system), but my device could have be damaged in the process thanks to Microschoft ("schoft" is a Dutch slang term for a bad and despicable person, so I did not make a misspelling), well no vital files appeared to be damaged (and I have a backup anyway).

But to make a long story short, how can I prevent Windows 10 from restarting my system without my permission while I'm sleeping or for any other reason AFK?

dawlane(Posted 2016) [#2]
Turn off Automatic Updates.
I should point out that it's not always guaranteed to work as some updates will turn automatic updates back on.
Or disconnect from the internet.

Tricky(Posted 2016) [#3]
Thanks.... I really wonder which idiot got the idea to reboot the system without asking the user's permission. I'm glad I didn't lose any (significant) data.

xlsior(Posted 2016) [#4]
when updates finish installing it will pop up a window asking you when to reboot, and gives you the option of "tonight" or schedule & postpone for up to 5 days later... If you don't pick anything, it will do it at 2 or 3 am local time.

Annoying, especially since you can't disable automatic updates altogether: If you do, it will automatically re-enable them after a while.