BMax 1.30 IDE Bug

Archives Forums/MaxGUI Bug Reports/BMax 1.30 IDE Bug

QuickSilva(Posted 2008) [#1]
I started to create a new program that just consisted of setting up the graphics mode and then a main loop and when I saved it the complete code turned to white text, by this I mean that there was no longer any highlighting of keywords. This went when I reloaded the file back in.

Nothing major just wanted to point it out.

I`m using WinXP Home.


(Sorry cannot recreate.)

SebHoll(Posted 2008) [#2]
Grrrrr.... I hate these sporadic bugs that can't be reproduced. It makes debugging really hard. Let me know if you find anything else out, and I'll keep an eye out for it myself.

QuickSilva(Posted 2008) [#3]
Sure thing. I`ll keep trying to replicate it so that you have something to work with. Your hard work on this is very much appreciated. The IDE is now far better than it has ever been. Are any new additions planned in the future after the stability is perfected? Nothing major just things like the ability to change the .exe icon from within the IDE etc...


QuickSilva(Posted 2008) [#4]
Happened again. I started the IDE, then typed in the following.

Then I saved the file (without running it first) to my Desktop and then the code in the IDE all turned to white. It only sometimes happens though as I have tried again several times without success. Sorry I cannot be more helpful.


Grisu(Posted 2008) [#5]
All fine here... :(

ChristianK(Posted 2008) [#6]
Text turns to white, when saving the file as 'non-bmx'.

SebHoll(Posted 2008) [#7]
Text turns to white, when saving the file as 'non-bmx'.

Yep, that is the desired behaviour. Non BMX files shouldn't have syntax highlighting. What QuickSilva (and I) have sometimes experienced is BMX files turning completely white for some reason (like non-BMX files). Reopening the files/IDE "fixes" the problem for me and it seems to happen randomly.

markcw(Posted 2008) [#8]
I found a similar bug in the BMax IDE for Linux, the bug is in the 1.30 IDE and in Seb's new builds. I never mentioned it because it's a low priority bug and because a random bug like that is only going to waste Seb's time when he could be fixing a more serious bug.

Anyway, here is how I reproduce the bug.

In BMax IDE, close all tabs and then browse to "samples/aaronkoolen/AStar/Callback.bmx" this file has very little text in it so is less confusing. Now just close that file and reopen it and repeat until the syntax highlighting doesn't load, it shouldn't take more than 10 trys.

I also just tried opening from the Recent Files tab and also just using the keyboard shortcuts for everything and the bug still occurs.

SebHoll(Posted 2009) [#9]
Do we still get this bug with the latest FLTKMaxGUI MaxIDE on Linux, or with Windows BlitzMax v1.33?

Grisu(Posted 2009) [#10]
Can't reproduce the bug here under win7.

QuickSilva(Posted 2009) [#11]
SebHoll : I still get it on Vista with v1.33.

SebHoll(Posted 2009) [#12]

SebHoll(Posted 2009) [#13]
Still get this with BlitzMax 1.36/MaxIDE 1.35?