nothing exists - not even variables

Archives Forums/Blitz3D Bug Reports/nothing exists - not even variables

tsmpaul(Posted 2011) [#1]
I don't know what's going on. I reinstalled my computer, and reinstalled blitz, and nothing wants to work in it. My programs don't do anything - they often run, but nothing is displayed, and in the debug window all of my variables have a value of zero.

I've tried reinstalling blitz3d numerous times, I've tried different patch version. Nothing will work anymore!

I tried a test program that simply assigned a number to a variable:


I ran it. The variable reads as 0 even though a number is assigned to it! Has anyone encountered this before? Any help would be greatly appreciated!

windows vista
4 GB ram
nvidia geforce 9800 GT

Blitz has ran perfectly fine until now - and I've reinstalled windows before with no problems. I don't know why it would stop like this.

Last edited 2011

Floyd(Posted 2011) [#2]
What about the sample programs that are included with Blitz3D?

If nothing is displayed with your programs the problem may be confusion about which is the current graphics buffer. The default for this changed some time in the distant past.

The Graphics command defaults to using the front buffer, while Graphics3D defaults to the back buffer. In the latter case you must use Flip to see anything. If the default behavior is inappropriage you can use SetBuffer to force whichever behavior you want.

If you can't get this to work then post a small sample program that tries to display something but fails when you run it. The one-liner you gave
is unenlightening. It doesn't attempt to display anything. Even in Debug mode it ends immediately so you don't know what it did. At least add a Stop command.

tsmpaul(Posted 2011) [#3]
Hi, I tried out the samples, and they are working...
It could be a debug error.

an example:

graphics 640,480,32,2
while not keydown(1)
print testvar

If I do that, it will type '1' down the screen, but looking at the debug window, it still says that testvar=0, while the program is running and displaying 1's.

While running my main program, the debugging was listing everything as 0 which made me believe nothing was working, as nothing appeared to be drawing onto the screen, but I worked out that in my main program, CameraRange was set to too high a value, and that if it is over a certain distance, it defaults to displaying nothing at all. Lowering the CameraRange distance, things are now visible, so my programs are working after all.

I was making the solar system using real-world unit distances, (1 unit = 1 km) but I will need to adjust my distance and sizing scales so that things can be visible to the camera. I'll make a much shorter camera distance, and simply have things that are far away fade into view when within a more reasonable viewing range of their location.

Not being able to see values of things in the debug window is still a little bit annoying though, but at least I can see stuff on the screen now.

Yasha(Posted 2011) [#4]
Err... I think that this is normal behaviour. The debugger on my machine does much the same thing, but if you stop the program to enter step mode, the values in the debug window will be correct. I think it just doesn't bother when you aren't stepping through on the assumption that you wouldn't be looking at the values without pausing the program.

Or did this work for you before? (In which case, I've had this bug for a long time!)

andy_mc(Posted 2011) [#5]
I know blitz has a problem when you work with huge numbers in 3d environments, might want to say something like 0.001 unit = 1 km if your doing solar system scale stuff, i.e. 1 AU = 149598000 km = 149598 units