Hardware incompatibility

Archives Forums/Blitz3D Bug Reports/Hardware incompatibility

Al Mackey(Posted 2006) [#1]
I just got a new laptop, a Fujitsu T4210, and no Blitz EXEs will launch on it. They pop up the small initial window, and then it disappears with no errors.

Compiling and running apps from the IDE has the same effect. Doing that with the debugger turned on permanently locks up both the debugger and the IDE.

The graphics chip is an Intel 945GM, and it seems to work fine with other DirectX and OpenGL apps. Even full games like CivIV play rather smoothly. I've installed the latest drivers I could find for it.

The OS is XP Tablet Edition 2005 SP 2. It's fully patched.

Please help!! I need my Blitz!

Al Mackey(Posted 2006) [#2]

This may have the same cause as the "No Mouse Connected" post a few posts down. The primary input device is the tablet screen, and its drivers are fairly wonky.

skidracer(Posted 2006) [#3]
Unfortunately Blitz3D is currently incompatible with Windows Tablet Editions. There is a workaround where you can disable the advanced pen input for individual applications I think.

From this thread:


Playing around with compatibility options, I found the solution to this problem. Right-click on the executable you wish to run and select "Properties". From there select the "Compatibility" tab. There is an option called "Turn off advanced text services for this program". Select this option and hit "OK". Now your programs should run!

This turns off the handwriting and speech recognition built into WinXP Tablet Edition. Blitz executables are quite happy to run at that point. I will warn you, you can't just turn the whole screen into a text recognition area and expect it to work. *FROWN* You'll probably need to use a keyboard for text entry (I have the Toshiba Portege M200 which has the keyboard built in).

Al Mackey(Posted 2006) [#4]
Ah, that works. Thanks!

t3K|Mac(Posted 2006) [#5]
but there is still no workaround for "no mouse connected" (on win2k). or did i miss something?