Bug in gnet

Archives Forums/Blitz3D Bug Reports/Bug in gnet

RepeatUntil(Posted 2006) [#1]
Hi Mark, Skid, or other being able to modify gnet.php on this site,

gnet, the system to track game in progress, written by Mark Sibly, is not working any more (see gnet here http://www.blitzmax.com/toolbox/toolbox.php?tool=61 ).
When sending a request to gnet.php, the php script returns:
"<br />
<b>Warning</b>: Header may not contain more than a single header, new line detected in <b>/home/blitzbasic/domains/blitzbasic.com/public_html/gnet/gnet.php</b> on line <b>97</b><br />"

I think you modified the gnet.php script, since from the package, line 97 doesn't make sense.

I think this is something very easy to fix. Please, could you fix this bug??
I am waiting for this to be able to release ETNA-gnet, which will have the same nice functionalities as gnet, plus there will be no slow-down when doing the request.

Thank you very much!

RepeatUntil(Posted 2006) [#2]
Does someone else can confirm this bug? Just run gnet that you can download from www.blitzmax.com/toolbox/toolbox.php?tool=61 and confirm that you have the same error.

2 identical bug report by 2 different persons will show BRL that there is something to do here................

King Dave(Posted 2006) [#3]

EDIT: I noticed the game does actually get listed [url=http://www.blitzbasic.com/gnet/gnet_servers.php]here[/url] anyway, so internally its still adding it to the list OK.

RepeatUntil(Posted 2006) [#4]
Yes, the game is added, I noticed that as well. So this is working OK on the php side, but on the gnet side (Blitz), you get a runtime error "unable to add server" and the program stops.
So this has to be corrected. This is surely a 5 mn fix in the php script, either which was modified, either because of a change in the php version. Please, BRL......

siread(Posted 2006) [#5]
Getting the same error here. Would like to try out gnet properly, so if someone could look at it... :)

RepeatUntil(Posted 2006) [#6]
Since Mark Sibly is around (>10 messages in last 2 days!!), maybe he could have a quick look at this bug-easy-to-fix??? Many thanks!!

siread(Posted 2006) [#7]
I've managed to set up my own gnet database on my website. I fixed the error simply by changing this line in gnet.php:

header( "content-type: text/html\ncache-control: no-cache\n\n" );


header( "content-type: text/html" );
header( "cache-control: no-cache" );

Obviously this will only work if you are hosting your own gnet db. :)

RepeatUntil(Posted 2006) [#8]
Thank you siread! You show that the fix is even less than a 5 minutes fix!! I want to use gnet on this site, so I will wait for the fix...

How long should Blitz users wait before BRL correct this 1 mn fix??? Let's see....

RepeatUntil(Posted 2006) [#9]
Hi Mark Sibly or Skidracer: could you use the simple recipe of siread and fix gnet on this site??? Thanks for your help, we are all unable to use gnet until it's fixed....

RepeatUntil(Posted 2006) [#10]
Any chance?

Ricky Smith(Posted 2006) [#11]
This still hasn't been fixed yet !!

RepeatUntil(Posted 2006) [#12]
2 months!!!!!! 2 months to wait for a 5 mn fix that only BRL could fix!!!! I really don't understand!!
I wrote a very nice lib using gnet, spending hours and hours for free, and everything is stuck because BRL doesn't want to do this fix!!

I am sorry, I really don't understand here...........

Ricky Smith(Posted 2006) [#13]
It would be most appreciated if this could be fixed. Gnet is unusable at present unless you have your own server.

skidracer(Posted 2006) [#14]
Please test and confirm this has been fixed.

RepeatUntil(Posted 2006) [#15]
Haaaaaaaaaaaaaaaaaaaaaaaaaa, thanks Skid, this is now working.........
If you could, don't forget to put the fix for the posterity also in gnet: www.blitzmax.com/toolbox/toolbox.php?tool=61

Barton(Posted 2008) [#16]
is solved!